HomeLubuntu

Lubuntu Team Standup
ActivePublic

Hosted by tsimonq2 on Thu, Jan 24, 4:00 PM - 5:00 PM.

Description

Weekly Lubuntu standup meeting to check in with the team.

Recurring Event

Event Series
This event is an instance of E16: Lubuntu Team Standup, and repeats every week.

Event Timeline

apt-ghetto declined this event.Jan 14 2019, 9:57 AM
hmollercl added a subscriber: hmollercl.EditedThu, Jan 24, 6:57 AM

I will not be able to assist today, I really wanted to do it, I have made a text with things I wanted to "talk":

software-properties-qt
still waiting for review on this, there has been a new release announced 0.96.32

update-notifier
It works when launched manually, now I'm working on how to make it automatically.
Initially I thought of cron, but a superuser cron cannot "write" in a users X to show de notifier.
At this point the best solution I've found is using a bash script that does:

while true;
   do
        /usr/lib/update-notifier/lubuntu/notifier.py -u ./upgrader.py >> /home/hmoller/update_notifier.log 2>&1
        sleep 3600
done;

That running background takes less than 100K according to qps.

LO and microsoft office xml.
Our LO with libreoffice-kde5 package doesn't add the extension automatically. This is problematic for MSOffice xml format because since it is a zip with another extension, w/o entension is recognized as zip. In kde the save dialog has multiple checkbox, none of them are present in our system.
workaround, instead of libreoffice-ked5 use libreoffice-gtk3. With LO-gtk3 the extensions are added automatically (w/o need of checkbox) and the other checkboxses are present (encrytion).
On LO 6.2 there will be a qt5 VCL, so we made want to move forward to that. I remember that @tsimonq2 made a lot of lobby so we could use LO-kde5, we might have to do that lobby again?
I'm not sure how we could change the VCL we use, changing the envvar SAL_USE_VCLPLUGIN to SAL_USE_VCLPLUGIN=qt5 should do the trick (in the tracker they talk about "set SAL_USE_VCLPLUGIN=qt5" but in our case I have used "export SAL_USE_VCLPLUGIN=qt5"), but I don't know if that works in ubuntu, in my case haven't worked. Maybe we need a libreoffice-qt5 package?

Network Managers Tray
I have had a little discussion with @tsimonq2 about nm-tray(qt) nm-applet (gnome) and cmst (conmann). LXQt folks love cmst, but it is the one that more resources consumes, even more than gnome-nm-applet (on the same system CMST >20M, nm-applet 9M and nm-tray 5M see screenshot in https://phab.lubuntu.me/T141#3570 ). nm-tray is incomplete, even for configuring a new wifi it opens a terminal, and you cannot configure a VPN. Porting whole nm-tray means porting every gui that is used for every VPN, look for the VPN gui the packages for nm-applet that should be ported.
network-manager-fortisslvpn-gnome/disco 1.2.8-2 amd64
network-manager-iodine-gnome/disco 1.2.0-3 amd64
network-manager-l2tp-gnome/disco 1.2.10-1 amd64
network-manager-openconnect-gnome/disco 1.2.4-1.1 amd64
network-manager-openvpn-gnome/disco 1.8.8-2 amd64
network-manager-pptp-gnome/disco,now 1.2.8-2 amd6
network-manager-ssh-gnome/disco 1.2.7-1 amd64
network-manager-vpnc-gnome/disco 1.2.6-2 amd64

hmollercl declined this event.Thu, Jan 24, 6:57 AM
kc2bez is attending this event.Thu, Jan 24, 7:04 AM
lynorian is attending this event.Thu, Jan 24, 1:41 PM