Page MenuHomeLubuntu

Calamares testing
Closed, ResolvedPublic

Description

There's been some funkiness with EFI and some filesystems and we really need to go through every combination of:

  • partitioning options (manual/automated)
  • encryption
  • partition table type
    • GPT before MBR
  • firmware interface
    • EFI over BIOS
    • bonus points for non-matching architectures, i.e. 32 bit EFI, 64 bit CPU
  • filesystem
    • ext4 is number one, followed by btrfs, then xfs, the other exts
    • jfs an reiserfs are essentially undeveloped by their original authors and so I'm a little less worried about them
    • does anyone even use Windows formats???
  • with or without network

Also: BIOS/GPT is kind of a strange mix. We shouldn't make that a priority.

FIll in the table below with results. Throw a clock in the results if you're working on one:

partitioningencryptionpartition tablefirmware interfacefsnetarchresultswho
automatednoGPTEFIext4yes64wxl
automatedyesGPTEFIext4yes64wxl
automatedyesGPTEFIext4no64wxl
automatednoGPTEFIext4no64wxl
automatednoMBRBIOSext4no64wxl
automatedyesMBRBIOSext4no64wxl
automatedyesMBRBIOSext4yes64wxl
automatednoMBRBIOSext4yes64wxl
manualnoMBRBIOSext4yes64wxl
manualyesMBRBIOSext4yes64wxl
manualyesMBRBIOSext4no64wxl
manualnoMBRBIOSext4no64wxl
manualnoGPTEFIext4no64wxl
manualyesGPTEFIext4yes64hmollercl
manualyesGPTEFIext4no64wxl
manualyesGPTEFIbtrfsno64wxl
manualnoGPTEFIext4yes64hmollercl
manualyesGPTEFIxfsno64wxl
manualyesGPTEFIxfsyes64wxl
manualyesGPTEFIbtrfsyes64wxl
manualyesGPTEFIjfsyes64wxl
manualyesGPTEFIreiserfsyes64wxl
manualyesGPTEFIreiserfsno64wxl
manualyesGPTEFIjfsno64wxl
manualyesGPTEFIext3no64wxl
manualyesGPTEFIext2no64wxl

Everything installs, but the install boots to GRUB recovery if it fails.

✳ Installer fails with a squashfs error:

Event Timeline

wxl created this task.Oct 17 2018, 11:12 PM
wxl triaged this task as Unbreak Now! priority.
wxl updated the task description. (Show Details)Oct 17 2018, 11:15 PM
wxl updated the task description. (Show Details)Oct 17 2018, 11:19 PM
wxl updated the task description. (Show Details)Oct 17 2018, 11:41 PM
wxl updated the task description. (Show Details)
wxl updated the task description. (Show Details)Oct 17 2018, 11:53 PM
wxl updated the task description. (Show Details)Oct 18 2018, 12:13 AM
wxl updated the task description. (Show Details)
wxl updated the task description. (Show Details)Oct 18 2018, 12:24 AM
wxl updated the task description. (Show Details)Oct 18 2018, 12:28 AM
wxl updated the task description. (Show Details)
wxl updated the task description. (Show Details)Oct 18 2018, 12:40 AM
wxl updated the task description. (Show Details)Oct 18 2018, 11:53 AM
wxl updated the task description. (Show Details)Oct 18 2018, 12:03 PM
wxl updated the task description. (Show Details)Oct 18 2018, 12:14 PM
wxl updated the task description. (Show Details)Oct 18 2018, 12:29 PM
wxl updated the task description. (Show Details)Oct 18 2018, 12:53 PM
wxl updated the task description. (Show Details)Oct 18 2018, 1:18 PM
wxl changed the edit policy from "Administrators" to "All Users".Oct 18 2018, 1:35 PM
hmollercl updated the task description. (Show Details)Oct 18 2018, 1:36 PM
wxl updated the task description. (Show Details)Oct 18 2018, 1:36 PM
hmollercl updated the task description. (Show Details)Oct 18 2018, 2:10 PM
hmollercl updated the task description. (Show Details)
hmollercl updated the task description. (Show Details)Oct 18 2018, 2:31 PM
hmollercl updated the task description. (Show Details)Oct 18 2018, 2:42 PM
wxl updated the task description. (Show Details)Oct 18 2018, 2:42 PM
wxl updated the task description. (Show Details)Oct 18 2018, 2:55 PM
wxl added a comment.Oct 18 2018, 2:59 PM

Seems like the problem is EFI/encryption so let's focus on testing all the variations of that.

wxl updated the task description. (Show Details)Oct 18 2018, 3:01 PM
wxl updated the task description. (Show Details)
hmollercl updated the task description. (Show Details)Oct 18 2018, 3:09 PM
wxl updated the task description. (Show Details)Oct 18 2018, 3:12 PM
wxl updated the task description. (Show Details)
wxl updated the task description. (Show Details)Oct 18 2018, 3:28 PM
wxl updated the task description. (Show Details)Oct 18 2018, 4:00 PM
wxl updated the task description. (Show Details)Oct 18 2018, 4:15 PM
wxl updated the task description. (Show Details)Oct 18 2018, 4:49 PM
wxl updated the task description. (Show Details)Oct 18 2018, 5:20 PM
wxl updated the task description. (Show Details)Oct 18 2018, 5:24 PM
wxl updated the task description. (Show Details)Oct 18 2018, 5:41 PM
wxl updated the task description. (Show Details)Oct 18 2018, 6:01 PM
wxl updated the task description. (Show Details)Oct 18 2018, 6:55 PM
tsimonq2 renamed this task from final 18.10 testing to Calamares testing.Oct 20 2018, 3:16 PM
tsimonq2 added a subscriber: tsimonq2.

Is there anything left to do here, @wxl?

wxl added a comment.Oct 20 2018, 9:08 PM

@tsimonq2 reiser being weird is kind of interesting.

tsimonq2 closed this task as Resolved.
tsimonq2 claimed this task.