Page MenuHomeLubuntu

Python 3.7 Package Migrations
Closed, ResolvedPublic

Description

[This is a master task for Python 3.6 -> Python 3.7 migration tasks]

Starting with Disco Dingo, the Python 3 default stack is now Python 3.7. This has led to several headaches, but according to the Ubuntu Release Team, they are working to fix the issues they've observed from Python 3.6 -> 3.7 migration in main and autopkgtests that they can address.

However, several other packages in Lubuntu do not run on Dingo, due to the 3.6 -> 3.7 migration, and may need rebuilt or adjusted, or have other migration related headaches.

Please add additional sub-tasks which relate to the 3.6 -> 3.7 migration of Python (and missing 3.6 requirements or similar problems) to this as subtasks and assign accordingly. This will be added to the 19.04 master task.

Event Timeline

teward created this task.Nov 13 2018, 2:03 PM
teward created this object in space S1 Public.
teward triaged this task as Unbreak Now! priority.
teward renamed this task from Python 3.7 Migration Tasks to Python 3.7 Migration.
teward renamed this task from Python 3.7 Migration to Python 3.7 Package Migrations.Nov 13 2018, 2:05 PM
teward updated the task description. (Show Details)
wxl closed this task as Resolved.Nov 20 2018, 5:22 PM
wxl claimed this task.

Looks like the last remaining thing was solved in rSEEDc8729c3a3541.