Page MenuHomeLubuntu

Lugito doesn't publish new posts
Open, HighPublic

Description

This is a bug, but lugito for some reason doesn't correctly create posts under Wordpress. I have to create a dummy draft post with the same slug as in the YAML and do the publish script after that.

The code is in there to automatically create the new post, but I guess it doesn't work?

Event Timeline

tsimonq2 created this task.Sep 17 2018, 2:39 PM
tsimonq2 triaged this task as High priority.Sep 17 2018, 2:44 PM
tsimonq2 edited projects, added Meta; removed Release Management.Oct 2 2018, 2:34 PM

@tsimonq2 Do you want to be check this one out? If you can provide the dummy post info that'll help too thx!

Sure thing!

I call it Lugito because that's our generic name I guess, but here: rBLOG Lubuntu.me Blog

Right now, it should just create the Wordpress post instead of just failing when it doesn't exist. Plus, that code and how things are working can probably use some significant reworking.

If you're open to taking a look, that would be wonderful!

doc-E-brown added a comment.EditedTue, Nov 27, 1:48 PM

A question regarding the workflow. I assume the posts are committed to phabricator before being published to wordpress. I was thinking a clean solution would be to put the functionality from these scripts into the lugito webhook and push the post to wordpress once it is committed. The diff would also automatically select between new posts and updates on the basis of the phabricator diff, What do you think?